[SOLVED] Crash | Running out of Space in C:Drive while running Lens Studio.


If you are facing this issues then give this a read.

Before Running Lens Studio do the following Steps.

Step 1


  • Run > %temp% (Type & Enter)

  • Select All (Shift + Del)

This will delete all temp files that "might be" responsible for crashing if any.

Step 2


  • Run > %appdata% (Type & Enter)

-Find Folders-

  • Snap > Lens Studio > Autosaves >
  • Inside Autosaves > Select All (Shift + Del)
    This will delete all your old backup that you don't even need. Which is also responsible for creating low space in your C:Drive.

Step 3


  • Run > %appdata% (Type & Enter)

  • Click on Appdata folder on top

  • (Goto Folder) : Local > Snap > Lens Studio > cache > temp >

  • Inside temp > Select All (Shift + Del)
    This will clear all the cache files which is causing crash to your lens studio

Reason for Crash :
1) While Starting Lens Studio it takes ALL into consideration all the old saved files + Cache which over loads your system causing crash.
2) Multiple Images can also cause crash because it compresses all at the same time which also over loads your system.
3) Using Photoshop & Editing Images and saving it directly inside your project files while lens studio is running can also cause crash.

Final Step


  • Open Lens Studio
  • > Preferences | OR | Press Ctrl + ,

By default it will be 99. But you can change it to 2 or 1. I choose 2.
*Max Backups Count - 2
*Max Backups per Project - 2

And Most Probably Your Lens Studio Low Space and Crashing issues would get solved.

If you have any more steps in mind or find an Error in the following steps. Kindly Comment below.

This Steps Works for me all the time


  • AMAN
    AMAN Posts: 1
    edited February 2023 #2


    Whenever I tried to create cloth or 3D body tracking lens, it crashes and instant closed. I've tried all (four) steps but still unable to create body-tracking/cloth-simulation based lenses. Please optimize Lens Studio by remove unnecessary files/templates.

    Current version (latest): v4.40.0