Why does Lens Studio and Snap Camera not work with my camera?

Options

Hello all! Thank you for viewing and thank you even more if you can help.
I'm going to release a video for my NFT project detailing how to make Lenses out of the .glb files from my NFTs. I've been using Lens Studio, and it works perfectly to preview and publish the lens when used on iOS. However, there are a few issues with desktop:

  1. When I'm in Lens Studio, a lot of times the preview panel will not load properly (more than half of the person is black pixels) and when I click "webcam preview" it will show my face for half a second and then freeze; when I switch from "Integrated Camera" to "Snap Camera", it will show my face (with the filter on it) for another half second and then freeze until I switch the camera again. I figured this wasn't a problem because I just clicked "send to snapchat" and waited 10-20 seconds for it to show up on my phone every time I wanted to test the lens.

  2. When I import .glb files that are 1-2MB, it takes about 12-20 minutes for the file to import into Lens Studio. Loading a project file or saving a project file takes 2-3 minutes to complete as well, and I feel this isn't normal, but I just dealt with it as doing everything else inside Lens Studio worked in realtime.

  3. I've published an example of the lens and how they will be after people publish lenses of their punks. Here's one: https://www.snapchat.com/unlock/?type=SNAPCODE&uuid=a9060a23794a43f6b5301024ba987dfd&metadata=01
    When I click it in Snap Camera, it does not load. The camera freezes and it never loads. I've tried on 10+ other lenses in Snap Camera and they all load immediately. I've also reinstalled Snap Camera to no avail. I don't remember the size of the lens file in the studio before I published it, but I published another lens very similar with the same scripts and types of .glb files, and it was 0.42MB, hardly a big lens at all. I've cleared the cache in Snap Camera, and it made no difference; the camera freezes and lens still never loads.

  4. In an effort to see if it's just my computer that doesn't work well with Lens Studio, I used my other computer (also 8th gen i5 processor with 12GB RAM) and Snap Camera doesn't even work with that computer. On that computer, I've reinstalled Snap Camera 3 times, I've uninstalled the "integrated webcam" drivers and reinstalled them, I've 10x checked the Windows setting to allow apps to use the camera (Snap Camera doesn't even show up on the 2nd computer settings even though it does on the main computer), I've restarted the computer multiple times, I've closed all processes in task manager that might use the camera, and I've cleared the cache in Snap Camera. It just says "no available camera input" and in settings it has "Integrated Camera" selected, but for camera resolution the dropdown menu doesn't let me click any options.

  5. I just tried the lens on Snap Camera on an old Macbook Air, and it still doesn't load. It puts on all other lenses in Snap Camera, but freezes when I click my lens. Why does my lens not work on Desktop, but works on iOS?

I initially didn't think much of the preview panel in Lens Studio not working and the webcam preview feature not working, but now I think it's linked to the problem of the published lens not loading when I click it in Snap Camera. Here's the information for my main computer:

  • Dell Inspiron 5579 - Windows 10
  • Intel Core i5-8250U @ 1.6GHz
  • 1 TB SSD
  • 16 GB RAM
  • Intel UHD Graphics 620
    I can share more details on the computer if requested.

Answers