Unable to open the project

Hi Guys,

I am facing this error Pop-up:-

Project not opened: "Exception in Engine! Can't open C:/Users/Jeetesh Singh/AppData/Local/Snap/Lens Studio/cache/temp/StudioMCHgrPHmHHiL/scene.scn"

I am unable to open a project made in the latest LS version v4.40.1. This project uses Body Tracking, Body Segmentation capabilities. I also made a new project from scratch with the same set of capabilities nothing complex and facing the same issue. I tried reinstalling lens studio but that didn't help either, I cannot upgrade LS even further as the version of this project is the latest.

While making this project from scratch doesn't crash until we close Lens Studio and try to reopen the same thing. Also tried sending the same file to another system and there I get another error

Project not opened: "Exception in Engine! [json.exception.type_error.302] type must be object, but is null"

Best Answer

  • Jeetesh Singh
    Jeetesh Singh Posts: 5
    #2 Answer ✓

    Hi Guys,

    Thank you for trying to solve this with me! So as an update, the problem got solved by SnapAR Support Team. They found the root cause to be a corrupted prefab which was causing the crashes in all of my projects. The Body Eraser Asset in the Project that I downloaded from LS Asset Library turned out to have a prefab that got corrupted, deleting the prefab from the project folder allowed me to then open the project without facing any crashes! I was so happy that the rework was saved!

Answers

  • Mosra 🇵🇹
    Mosra 🇵🇹 Posts: 22 🔥

    Good morning,
    files may be corrupted, which creates this problem

  • This happened even after I made a new project, what files are corrupted and how is it getting corrupted? I even asked one of the other creators @Krunal Bharat Gediya and he faced the same problem with a recent project, which seems like a bug in Lens Studio itself. We suspect maybe it has something to do with body segmentation, as that was common in our projects. But we need a resolution! If anyone can help in recovering the project!?

  • aidan
    aidan Posts: 32 🔥

    Try deleting the Lens Studio cache and reinstalling Lens Studio. My guess is there's an incompatible file that was generated by a previous version of LS and its messing up the newest version.

  • Hey @aidan so I tried your solution, didn't work. I cleared both local app data and app data and reinstalled LS v4.40.1. It still crashed when I opened my project. Guess the only solution looks like the worst case that is making it from scratch again 😓

  • Hi all! I am getting the same issue with a Lens we are creating.

    It seems like if I mix 3D body tracking and segmentation, link up my 3d objects bones, add two Uber PBR materials with normal blend mode then two other Uber PBR materials with alpha test as the blend mode, then save the file, I can no longer open it on the next go.

    I tried all of the steps up until adding the materials and was able to re-open the file. Once I added the materials it was a goner.

    I have tried a few different ways of rebuilding this to debug. I also tried just importing the 3D object and adding the files without segmentation and 3d body tracking. This allowed me to re open the file.

    I'm not sure where to go from here.

    Many thanks for any assistance anyone can offer.

  • Hey @Marc Wakefield is your project using body eraser prefab? In My case the prefab was corrupted, deleting which I could make it reopen. If you think you're pretty sure that your materials are the issue then can you delete the materials from the project folder and then be able to reopen the project? If not then the root cause could be something else. Let us know if materials were causing it or something else!