Lens not working in Snap Camera

Options

The face mask lens I'm making in Lens Studio isn't showing up correctly in Snap Camera. It works on Snapchat but not Snap Camera. Instead of the face mask lens I'm getting a purple and black checkered pattern. Can't figure out why. Please help.

Best Answer

Answers

  • Capystrim
    Options

    I have the exact same issue. My lenses work just as it should in snapchat on my phone, but the texture always ends up as purple and black in snap camera on desktop..

    Would also like a solution to this problem. :)

  • Pedro Machado
    Options

    Same issue.
    I have created a new lens from an existing one (baseball cap) and it works fine on android Snapchat app, but when trying to use it on Snapcamera for Windows the cap shows as pink and black checkers.
    (It should be white with a logo).

    Thanks

  • Hi @Robert Keith

    If you do not get a clear answer, contact the dedicated technical support via the following link
    support snap camera

  • sky2
    sky2 Posts: 1
    Options

    experiencing something similar, any update to this issue?

  • Drew
    Drew Posts: 3
    Options

    also looking for answer!

  • marieeve
    marieeve Posts: 7
    Options

    Me too :) and I contacted the support team, their answer was the following:

    -We’re sorry to hear that you’re having issues with Snap Camera. We really appreciate you taking the -time to let us know more about your problem. Now, we can try to find a solution for you and the rest of -our community 🤗

    -In some cases, we might need to ask a few follow-up questions, so keep an eye out for that 👀 Our -community is part of what makes Snapchat so special and strong. We couldn’t do it without -Snapchatters like you 👻 Thanks so much for your help!

    I do hope they will find a solution.

  • Melissa Cameron
    Melissa Cameron Posts: 2
    edited July 2022 #9
    Options

    I made a new lens that works in snap chat but not in snap camera, which it was meant for. The camera just freezes, and nothing loads. We have the latest version of both programs. We tried publishing and testing a template lens, only changing one aspect, but all we got in Snap Camera was black and pink checker board. Anyone have a fix?

  • Chema Mat
    Chema Mat Posts: 1
    edited July 2022 #10
    Options

    I have the same problem... I have used a template (3D objects), I have only changed the 3D object. In Snapchat it works perfectly, but in Snap Camera the camera freezes when I select my filter....
    Link

  • snoopyuj
    Options

    If you just add a gauss blur effect to an empty project, it won't work, either :(

  • marieeve
    Options

    Yesterday, there was an update to Lens Studio v.4.25, I upgraded and re-published some lenses today and they still have the same problem in Snap Camera, black and pick checkerboard on the textures. Hope someone will find a solution soon :)

  • Phillip Shoemaker
    Options

    I have been struggling with this issue as well. All of my lenses work fine in Lens Studio, but once they are on Snap Camera, I get the black and pink checkerboard on all of the textures in all of my lenses. How do we fix this?

  • Akshay
    Options

    Hii,
    I'm having the same issue my lens is working fine in snapchat mobile app but its not working in snap camera desktop.
    can someone help me with this.

  • Alan Araújo
    Options

    I have the same issue. Many lens that worked before, now won´t work anymore. I think is some compatibility with graphic card and new SnapCAM versions

  • Joni
    Joni Posts: 2
    Options

    yep i think PC versio snap cam is history, support has no will to even try to fix these.

  • ppppoop
    Options

    Bahajjsjsjsjs

  • Hash 🔥
    Options

    same problem here except the whole screen is checkered like that

  • Apprentice
    Apprentice Posts: 41 🔥
    edited November 2022 #19
    Options

    Same here, texture and object have no render!
    Best software bugged ever i'have seen!
    (Same No Man Sky V1.0 Joke :) )
    Just Moving to other AR app. Tired to say "bye bye" my work
    And i am a noob in 3D
    A professional must laugh :|

  • Apprentice
    Apprentice Posts: 41 🔥
    edited November 2022 #20
    Options

    And guys! If you update your lens Studio = byebye your project
    A pleasure
    I think THIS IS your really problem; you have update your project and this is bugged like never afetr!
    Same problem here!
    I have a project in 4.28 and when i update him to 4.31 = Bugged = Texture can't be render

  • Apprentice
    Apprentice Posts: 41 🔥
    edited November 2022 #21
    Options

    Never update your project to resave at "new name project"
    This will be update your project in the last vesrion!
    Juste copie the folder and start whit him and save it afetre your work
    Yes; it's totally idiot :(
    Working fine here but ... My head are broken

  • KreJaxx_YouTube
    Options

    Im having the texture render problem in 4.34 with pngs

  • Daniel
    Options

    Same problem here, i hope they fix it soon

  • Hayley Crisp
    Hayley Crisp Posts: 3
    edited July 5 #24
    Options

    If you're facing an issue with your face mask lens in Snap Camera, it might be due to a texture loading problem. The purple and black checkered pattern you see typically indicates missing textures. Ensure all assets used in the lens are correctly included and referenced in your Lens Studio project. Additionally, check that the lens is exported properly and is compatible with Snap Camera's requirements. This attention to detail is as crucial in digital projects as it is in creative services like Logo Design Services in New Jersey. Re-exporting the lens with these considerations in mind might resolve the issue.