Randomly no longer allowed to upload/update lenses

Options

Last night I ran into this issue where if I try to upload/publish a lens onto my account I get a message saying "Denied" followed by a text saying "You don’t have access to submit to the selected organization with the current visibility setting. Please use Do Not Publish to Snapchat." And if I find a way to upload the lens without having this denied message pop up then my lens is automatically invalid with an error message saying "The Lens Folder and Organization for this Lens do not match the Organization for one or more of the remote assets" Never in my life would I imagine having such a disabling issue for uploading snapchat lenses but all of a sudden it seems like I just simply cant upload lenses to my account anymore. I tried contacting Lens Studio Support and they told me to upload to my ads folder instead and publish to my account there but if I do that I still get the denied message so im at a dead end and a loss of words here. I have multiple clients that depend on this stuff to work.