Facing constant errors while downloading Lens Studio v4.53

I have tried downloading the latest version of Lens Studio using the official website https://ar.snap.com/download
However, I ended up seeing this screenshot pop up after I tried opening the application.
It asks me to provide Lens Studio, Camera access.
All the permissions are already enabled.
I have tried uninstalling and redownloading but nothing is helping.

Any help would be appreciated.

Error screenshot - https://photos.app.goo.gl/VemBBimADwURLKBP7
Permissions enabled - https://photos.app.goo.gl/hxs5rAvX5NzgB22e8

Tagged:

Answers

  • Bakari Mustafa
    Bakari Mustafa Posts: 174 🔥🔥🔥

    Hi @Prana Art, try to uninstall Lens Studio again, and this time, after uninstalling, manually delete any remaining cache or preference files related to Lens Studio. Then, reinstall Lens Studio.

  • @Bakari Mustafa Thank you for your help, but it is still not working; I am even facing the same error downloading older versions. However, when I download it from the App Store (it's working) but the version is v4.49