ML Eraser stopped working

ocean.sips Posts: 14 🔥
edited December 2022 in SnapML #1

Hi. I was using ML Eraser to delete a body. But today, it stopped working.

I tried reopening different projects where I use it, and it's the same.

I tried deleting the object and adding it again.

I also tried deleting the asset from the library and installing it again.

Nothing is working, and the effect looks terrible. See the picture. It's supposed to remove the body but instead, it adds a strange blur to the entire scene.

Working example (yesterday and earlier today)

Buggy result (today starting an hour ago)

Any clue what could be happening?


  • ocean.sips
    ocean.sips Posts: 14 🔥

    I found the issue. It's a weird bug. But I'm quite sure it's a bug an not a feature.

    As soon as I add a second Segmentation Texture to the library, the ML Eraser starts misbehaving. That makes no sense, since the texture is only in the library, not even being used in the objects hierarchy.

    I recorded a video to showcase the issue.

  • Ya , whenever there is a new thing I immediately try to figure out how to break it and this one was pretty easy. Of the 2 ML eraser lenses I made both have segmentation [skin and clothing respectively] which basically does not work once I import and test on my physical phone. The eraser works but the segmentation is, well the blurryness is contained to an area but that ends up being most of the screen. It completely breaks when you combine a segmentation texture with a background targeting function like for EG: ML eraser masked to skin segmentation and another object that has background segmentation of any kind or related segs. That breaks it, had to fully scrap the backups even, I think it's because of the Eraser being by default a background segment function so if you throw some post fx over that background [specifically not globally] even out of order it creates a problem loop or doesn't compute reasonably enough for a mobile CPU to entertain threading