Build error with templates

kjiroh Posts: 3
edited May 2023 in Getting Started #1

Hi there,

I installed lens studio 4.46.0 today and started installing templates to my iPhone 12 mini (iOS 15.4.1)

I got a shader build error with all template I tried below when I sent to my SnapChat. I didn’t change any on templates.
- Face In Picture
- Face Mesh
- Face Expression
- Segmentation
- Distort

No templates work on my iPhone. I haven't tried others, but maybe I get the same error.

When I open lens I installed, I got this error for all lenses I installed. (but the line numbers are different for all lenses)

Error running lens, please try again.

[Snenarium] Vertex Shader build error:
1614: void main()
1615: {
1616: if (IsProxyMode())
1617: {
1618: sc_SetClipPosition(vec4(position.xy,depthRef,1.0));
ERROR: 0:1616: Invalid call of undeclared identifier

How can I solve this?

Best Answer

  • kjiroh
    kjiroh Posts: 3
    #2 Answer ✓

    I deleted SnapChat app and installed it again from the AppStore. Now it’s working!


  • kjiroh
    kjiroh Posts: 3

    I updated with my iOS to 16.4.1. Still doesn’t work. But I send lens to my android smartphone, it works.
    Lens studio app doesn’t work on iPhone mini 12?