Randomly no longer allowed to upload/update lenses

Last night I ran into this issue where if I try to upload/publish a lens onto my account I get a message saying "Denied" followed by a text saying "You don’t have access to submit to the selected organization with the current visibility setting. Please use Do Not Publish to Snapchat." And if I find a way to upload the lens without having this denied message pop up then my lens is automatically invalid with an error message saying "The Lens Folder and Organization for this Lens do not match the Organization for one or more of the remote assets" Never in my life would I imagine having such a disabling issue for uploading snapchat lenses but all of a sudden it seems like I just simply cant upload lenses to my account anymore. I tried contacting Lens Studio Support and they told me to upload to my ads folder instead and publish to my account there but if I do that I still get the denied message so im at a dead end and a loss of words here. I have multiple clients that depend on this stuff to work.

A decent solution I found was to publish under a different organization with remote assets that are under this different organization. This does mean however, that any lenses I have under the original organization cannot be updated until this issue is fixed.

Comments

  • stevenxu
    stevenxu Posts: 542 👻

    @mrm.designs Thanks for posting on the forum. Confirming I've created an eng ticket to look into this for you (4779). Hang tight

  • ForumChris
    ForumChris Posts: 23 👻

    Hello @mrm.designs for Remote Assets the Lens will need to be uploaded to an associated organization's Lens Folder as that is how the Assets are validated.

    Non-Remote Asset Lenses should still be able to be uploaded through the previous flow. Can you confirm in Business Manager (business.snapchat.com > Members) that you have the proper settings within this organization to upload Lenses to ?