Push2Web not working - Camera Kit Web

alex_doudnikov Posts: 14 🔥
edited October 2023 in General #1

Hi everyone,

Push2Web has not been working for me across various web browsers (chrome, edge, firefox). I am signed into the same snap account on web and lens studio. After I send the lens in Lens Studio nothing happens in my web browser for a few minutes.

I have tried disabling all of my extensions, incognito mode, and disabling some ad protection on my network as a final measure. None worked.
I have added the usernames to the camera kit app in the dev portal.

Other camera kit features/pages work fine, just this specific feature has not worked for me.

Any advice?

Lens Studio Version: 4.55.0 (Latest at the time of writing this)
Camera Kit Push2Web Demo: https://camera-kit.snapchat.com/websdk/sample/push2web



  • JacekC
    JacekC Posts: 19 🔥

    Thank you for reporting this problem. There shouldn't be anything else required from you other than using the same Snapchat account to sign in on the Camera Kit Push2Web page: https://camera-kit.snapchat.com/websdk/sample/push2web and in the Lens Studio.

    To debug the problem, do you see any errors in the web console?

    Also, if you sign in with the same account in the Snapchat app and use in Lens Studio an option "Send to All Snapchat", will that send your lens to the Snapchat application? I wonder if it's not working just for Web or in general.

    Last thing to check is the paring with the Snapchat account in the Lens Studio. Can you please check the "Pair new Snapchat Account" option and see if this will improve anything? (*button might be called "Preview on Device" if it wasn't done before).


  • alex_doudnikov
    alex_doudnikov Posts: 14 🔥
    edited October 2023 #3

    When sitting on the Push2Web page after initializing I get a 504 timeout. (Firefox and Chrome had the same 504)

    Firefox: XHRPOST https://api-kit.snapchat.com/com.snap.camerakit.v3.PushToDevice/ListenLensPush [HTTP/3 504 15048ms]
    Chrome: Failed to load resource: the server responded with a status of 504 () 1 https://api-kit.snapchat.com/com.snap.camerakit.v3.PushToDevice/ListenLensPush

    Github Gist of the error in firefox: https://gist.github.com/PT-Alex/81a08fc8bafd489afc37ece613e6b164

    Once I paired a device signed in with the same account that was signed in on the Push2Web site and L Studio, Push2Web started working when I hit "Send to All Devices". (Sending to device worked fine)

    I would guess lens studio needs the push2web account device connected to send the lens to push2web. Could be worth noting in the docs as I test with many devices with different accounts just fine. I had the LS managed account paired to push2web but no device with that account paired so the pushes never worked.

    I managed to retain my lenses and submit lenses LS functions to the managed account by pairing my test account device and logging into push2web with the test account.

    Thanks for the help Jacek!