Push2Web LensExcludedError

Hi,

I am porting a lens studio 4.55 lens to camera kit and can't get push to web to work.

I tested with other projects and get the same error.

I am signed in with the same snap account on lens studio, paired device, and push2web.

Error:
Lens excluded
LensExcludedError

Any help would be appreciated, thanks.

Comments

  • JacekC
    JacekC Posts: 19 🔥

    Hi,
    Just to understand the problem better, if you push to Snapchat app, is that working?

    Knowing this will help us narrow the issue to web only.

  • This is only on the push2web sample page, device pushing works fine. I do not have a push2web system in place for our application.

    https://camera-kit.snapchat.com/websdk/sample/push2web

  • JacekC
    JacekC Posts: 19 🔥

    ok. And it's broken for all lenses, even a simple ones? If a lens is using capabilities that are not yet supported by web sdk, you may hit the problem with pushing to web.

  • These lenses have been uploaded and do work on camera kit, and I did test with them on push2web previously. I am making revisions to them now and wanted to use push2web for faster preview & testing.

    I received the same error using the countdown template lens just now.

  • JacekC
    JacekC Posts: 19 🔥

    Just fyi that we believe we got a local repro and we are investigating the problem. If you have any new observations that might help us understand the issue better, please do not hesitate to share them.

  • Thanks for the update, will do.