Objects doesn't reappear according to Behaviour Script

Options

Hey,

I was wondering if anyone would be able to assist with the issue I'm experiencing. Currently I have 2 behaviour scripts created via the helper scripts and it does not appear to be working as I intended it for. I have an object that I want to be shown only on the back camera so I have used the following formation in scripts (will be shown in images through imgur link). Although it appears to work fine, it works only once and then ceases to work again. Upon having it set to the back camera it will show (as I want) and then not appear on the front camera (as I want). Upon switching to the back camera again from the front camera, the object does not appear according to the script that I have used. Would appreciate any guidance/solution to this issue :smile:

Link to Images:
https://imgur.com/a/IpB1o5e

Thanks!

Answers

  • Dr. | حسن
    Options

    hello, I see that you are using glasses which you need to provide head binding ..

    for the 1st script try make these step

    trigger : back camera
    : set enabled
    entity response : component
    target .... : head binding
    actions : disable

    for the 2nd script

    trigger : front camera
    : set enabled
    entity response : component
    target .... : head binding
    actions : enable

    your object will work only with front camera

    good luck

    Hassan

  • Richard Tong
    Options

    Hey,

    Thanks for that, unfortunately it is still not working as I would like. I am unable to make the specific object a head binding as I want the object to permanently be visible in the frame as opposed to attaching when it detects a face.