Updating Community lenses now that I've created a Lens Folder

I tried to update an existing Community lens this morning. After hitting Publish in Studio, I was prompted to 1. create an organization and 2. create a lens folder. After going through these steps, the flow led me to an empty folder.
My community lenses still exist, but I can't figure out how to update them.
Any ideas? I don't want to creating new codes/links for the lens because I'm pointing to the old one on a website and a scan code.


  • audun
    audun Posts: 302 🔥🔥🔥

    I'm not sure we get the same page as I can't see the same options, but this is what I get after clicking "Submit" from the Lens Studio.

    Clicking "Community Lens" gives me the option to update existing ones.

  • Ah, yes! I must have been trying to upload during an update on the CMS. I see what you shared, @audun . Thanks a lot!

  • stevenxu
    stevenxu Posts: 582 👻

    Thanks @Andrew Deutsch for the post and @audun for the detailed response!

  • I take that back, @stevenxu - I had installed an older version of the app when opening a file created with an older version. When I reinstalled the new version, the issue returned.
    Installing the latest and greatest, I can't update a community lens. I'm sent directly to this screen when I try to publish an effect.

  • I've also had this issue after updating to 4.22 and wanting to update a 4.19 community lens (with a Snapcode that was printed).
    Since 4.22 using some features fall under "Lens Cloud".
    So using a Custom Landmarker as example and that falling under Lens Cloud it activates lens folders. If you are using the "Camera Kit" feature there is a "legacy flow" available.
    I've had some back and forth with support on this (letting them know that I was not pleased with them just enabling a "Beta" feature) but for me the only way to update the old way was to go back to LS 4.19. Luckily I was able to open my 4.22 project in 4.19 with minimal issues.

    This probably won't help you get rid of the issue but hopefully give you some insight on why this is happening.

  • Thanks, @Simonsaysnl . That was my guess.
    I'm trying to reach support for a link to the 4.19 installer. I'll keep those old dmgs on standby from now on! I tried installing the latest update to see if that would help and now I can't reinstall 4.19 when trying to load a 4.19 file.
    Thanks for confirming it's an issue!

  • No problem, here is a link to a LS 4.19 dmg I've put on drive (copy from version that support send me)

    Would indeed be nice if there was an official LS version archive from Snap

  • Amazing, thank you, @Simonsaysnl !

  • Yukin
    Yukin Posts: 1

    You are an angel, really! @Simonsaysnl Had another issue with 4.22 and needed an older version and had to make it work til tomorrow... have been searching all over the internet and almost gave up... thank you so much for sharing! it now finally works!

  • Kevando
    Kevando Posts: 76 🔥🔥

    @Andrew Deutsch lmk if you still need the 4.19 dmg you can DM me on twitter @kevando_

  • Kevando
    Kevando Posts: 76 🔥🔥

    How do I move a lens from one lens folder to another? I made some careless publishes and it's all a big mess now.

  • sunnyali003
    sunnyali003 Posts: 1
    edited November 2023 #13

    You need to update community lenses, when you've created a Lens Folder, simply drag and drop your existing lenses into the new folder. If your platform supports it, you might also have the option to right-click on a lens to add it to a folder. Remember to check for any platform-specific guidelines for organizing lenses in folders.