How to add a Platform at Platform Identifiers section for an approved application?

Hi Team, Our app was approved by your team and it is live now. I am trying to add a Platform at Platform Identifiers section for Production but it says Can't add a Platform Identifier for an approved Application.

Is there any way to add a Platform Identifier for an approved application (or) do I have to create a new application?

Please advise regarding this.

Thank you.

«1

Answers

  • cdublin
    cdublin Posts: 2 👻

    Hey there! Thanks for the question! We'll get our Support and Engineering teams to look into this.

  • stevenxu
    stevenxu Posts: 542 👻

    @AliveNow Creative Tech

    You can create a clone of an approved version and makes changes to it. No need to create a new application, just a new version would suffice. However, please note that platform identifier is not used in Camera Kit integration, only the App ID and API Tokens are used.

  • Yeti
    Yeti Posts: 1

    Not work for me

  • Hi there!

    Last week we sent a request to the Support team but I decided to repeat the question here so that the community could share their experience.

    For our app Customuse, CreativeKit integration doesn’t work in production.
    App gets an error_description_encryption_metadata_read_failure exception when trying to use shareLensToCameraPreview.

    And likely this is linked with errors described above.

    Platform Identifier for Production stage is missing in the SnapChat DevPortal, but there is no way to add it - the Add Platform button is blocked with a hint saying Can't add a Platform Identifier for an approved Application.

    As suggested above we created a New Version. Though the Add Platform button was blocked, clicking on it gave an Invalid platform identifier error. Then we sent the version to review and got an approval. Same thing - the Add Platform is still blocked.

    Could you please advise what should we do to configure the Production stage?
    And also - is it really true that we need to have different bundle ids for dev and production stages of the same application?
    How to approach this?
    https://github.com/Snapchat/creative-kit-sample/issues/6

    Thank you,
    Dmitry, Customuse team

  • stevenxu
    stevenxu Posts: 542 👻

    @Customuse Thanks for posting on the forum and apologies for this confusing issue. Let me investigate this with our team and I'll get back to you on what they share.

    Also curious was the support team able to respond back to you? This'll just help me align with them on the same internal ticket.

    Steven

  • @stevenxu Great, thank you. We haven't heard back from the support team yet.

  • stevenxu
    stevenxu Posts: 542 👻

    @Customuse Copy that and again apologies for that :'(

    But fear not! I got your back. Hoping to get back to you by Thursday morning latest. Hang tight.

  • @stevenxu Thank you! Looking forward to the solution.

  • Dipo
    Dipo Posts: 2
    edited April 2023 #10

    Hey was there any update on this? Im having the same issue for an approved application

  • stevenxu
    stevenxu Posts: 542 👻

    @Customuse @Dipo TLDR so far is that we're working on address this challenge. In the meantime, we have a working path to add the platform identifiers for you. I'm going to open a direct message channel for you to share this with me and we can resolve it there.

    Also @Customuse - Triple checking - what is the problem you're solving with adding the platform identifiers? Is it to resolve the Creative Kit integration failure you're having?

  • Hi @stevenxu. Exactly. For the production version, CreativeKit fails with error_description_encryption_metadata_read_failure exception.
    Bundle id is not added for the production stage, so probably that's the problem.

  • stevenxu
    stevenxu Posts: 542 👻

    @Customuse I'm getting closer... I'm targeting Wednesday latest for next update / steps to resolve. Appreciate your patience.

  • Hey @stevenxu

    the issue was resolved after your team manually added the bundle id to the production stage.
    Everything works now.

    Appreciate your help!

  • stevenxu
    stevenxu Posts: 542 👻

    @Customuse Thanks for closing the loop here on forums!! Appreciate your patience and know that our team is working on improving this bundle id process in the future. B)

  • Mat001
    Mat001 Posts: 2

    Hey @stevenxu

    I'm experiencing the same issue with the "Add platform" button being blocked, resulting in the "Can't add a Platform Identifier for an approved Application" message. Could you please share any updates on when this might be resolved, and any possible workarounds for adding my app id in the meantime?

  • stevenxu
    stevenxu Posts: 542 👻

    Hi @Mat001 ! Thanks for posting on the forum. One option you can do is make a copy of your approved version and add the bundle id from there. You'll just have to submit your app for review and I can help prioritize that for our team to take a look if you're on a tight schedule.

    The other option is we can add it manually like we did earlier in this thread though this may take longer depending on eng's bandwidth.

    Let me know

  • Mat001
    Mat001 Posts: 2
    edited June 2023 #18

    @stevenxu I can't add new bundle id, when I create new version the "Add Bundle ID" still says "Can't add a Platform Identifier for an approved Application"

    Adding platform identifiers is tight to "Setup" tab, when creating new version we have a new tab called with the version name, and there is no "Platform Identifiers" section.

    Could you kindly inform me of the fastest way to have it added? Would it be preferable to create a new app myself or should I rely on your assistance to submit it?

  • stevenxu
    stevenxu Posts: 542 👻

    @Mat001 Ah I see the issue! Okay, let's go with the second option (manual add). I'll start a direct message with you on this platform for privacy reasons to get the information needed to fulfill this. Hang tight!

  • @stevenxu said:
    @Mat001 Ah I see the issue! Okay, let's go with the second option (manual add). I'll start a direct message with you on this platform for privacy reasons to get the information needed to fulfill this. Hang tight!

    Hello, I have encountered the same problem, and now the Android platform has passed the review. However, the prompt "Can't add a Platform Identifier for an approved Application "is displayed when adding an iOS platform. Can you share how to solve this problem and the ID of my application that can be added。Thanks

  • stevenxu
    stevenxu Posts: 542 👻

    @dokie5021 Thanks for posting on the forum! Apologies on this issue you're having.

    Just copying and pasting the prev instructions: One option you can do is make a copy of your approved version and add the bundle id from there. You'll just have to submit your app for review and I can help prioritize that for our team to take a look if you're on a tight schedule.

    The other option is we can add it manually like we did earlier in this thread though this may take longer depending on eng's bandwidth.

    Let me know

  • @stevenxu said:
    @dokie5021 Thanks for posting on the forum! Apologies on this issue you're having.

    Just copying and pasting the prev instructions: One option you can do is make a copy of your approved version and add the bundle id from there. You'll just have to submit your app for review and I can help prioritize that for our team to take a look if you're on a tight schedule.

    The other option is we can add it manually like we did earlier in this thread though this may take longer depending on eng's bandwidth.

    Let me know

    Dear,

    We have the same issue, could you help us add it manually?

    Thanks!

  • stevenxu
    stevenxu Posts: 542 👻

    @ShiErKe Just messaged you!

  • @stevenxu said:
    @ShiErKe Just messaged you!

    Dear, the issue still exists, could you help resolve that. I have replied you in the message. Thanks!

  • stevenxu
    stevenxu Posts: 542 👻

    @ShiErKe on it!

  • @stevenxu said:
    @ShiErKe on it!

    Issue still exists for us as well (unable to add a platform identifier even with a new version), could I message you?

  • Hi @stevenxu we are experiencing the exact same issue with our Platform Identifiers during our rebranding effort, and on a tight timeline with our relaunch. We would be so grateful if you could send a direct message so that we can fix the issue manually!

  • stevenxu
    stevenxu Posts: 542 👻

    @albing @samuel_mueller messaged you!

  • Hi @stevenxu thanks for reaching out, we have replied in the direct message, let us know next steps

  • stevenxu
    stevenxu Posts: 542 👻

    hey @samuel_mueller ! Thanks for your patience and apologies for the delay. Let me get on this by end of day today. B)

  • Hi @stevenxu we've got exactly the same issue as well, can't add a production bundle id of iOS app neither in a Setup tab ("Can't add a Platform Identifier for an approved Application") nor in the newly created version (there's just no such option to add extra Bundle Id). Could you please help us to fix it manually in direct messages? Many thanks!